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Swiss Audio head units are compatible with virtually all audio components available today. Whether you’re looking 
for something simple and resourceful to play CDs and enjoy the radio or you’d opt for a head unit that can facilitate 
various media like CD/R/RW, MP3, WMA, DVD or even DAB (Digital Audivo Broadcast) in Europe, Swiss Audio has 
the perfect head unit to fit your needs.

Head Units

SDVD10 - Slot Load DVD Player
» CD, CD-R, CD-RW, and MP3 playback 

» DVD, Audio CD and MP3 CD Compatibility

» Wireless Remote Control Included

» Repeat Function

» Chapter Repeat & Replay

» Digital Audio Output (Coaxial)

» Multi Functions : Fast Forward & Reverse

» DVD : 2x, 4x, 8x, 16x, 32x, 64x

» CD/MP3 : 2x, 4x, 6x.

» Zoom Mode Function : 1.5x , 2x , 3x

» Front Panel A/V Input

» Optical Semiconductor Laser (DVD : 1-beam, CD : 3-beam)

» Video Output : Component X (2)

» Audio Output : 2 Channel Stereo X (2)

SDV3107 - DVD/MP3 Receiver/7” Motorized LCD Monitor 
» CD, CD-R, CD-RW, and MP3 playback  • Beat EQ • remote •changer control 

» Hi-Power - 4 x 40 Watts with Dual 1 bit D/A Converters

» Track Scan, Repeat, Random Play, Pause, Next/Previous,

» Detachable Faceplate

» Beat EQ preset: Flat, Classic, Pop M, Rock and DSP off

» S-Bass Sound Shaper Contour w/ Indicator

Tuner Features:
» 18FM/6AM Presets 

» Seek, Scan, Station Name Memory, FM Noise Blanker

» Multi-Path Rejection

» Aux Input for SDVD10

» Control Display: Backlighting- Swiss COOL BLUE illumination

» LCD Display:  Negative Image 12 Digit Swiss COOL BLUE 

» Mounting Capability ISO/DIN Chassis

» Elect: Volume, Treble/Bass, Balance, Fader

» 4 Channel Pre-Amp outputs (Front/Rear)
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Head Units

SCD1100C - CD, CD-R, CD-RW, and MP3 playback 
• Beat EQ  • remote • changer control 
» Hi-Power - 4 x 40 Watts with Dual 1 bit D/A Converters

» Track Scan, Repeat, Random Play, Pause, Next/Previous,

» Detachable Faceplate

» Beat EQ preset: Flat, Classic, Pop M, Rock and DSP off

» S-Bass Sound Shaper Contour w/ Indicator

Tuner Features:
» 18FM/6AM Presets 

» Seek, Scan, Station Name Memory, FM Noise Blanker

» Multi-Path Rejection

» Aux Input for SDVD10

» Control Display: Backlighting- Swiss COOL BLUE illumination

» LCD Display:  Negative Image 12 Digit Swiss COOL BLUE 

» Mounting Capability ISO/DIN Chassis

» Elect: Volume, Treble/Bass, Balance, Fader

» 4 Channel Pre-Amp outputs (Front/Rear)

SCD2100C - CD, CD-R, CD-RW, and MP3 playback 
• Beat EQ  • remote • changer control 
» Hi-Power - 4 x 40 Watts with Dual 1 bit D/A Converters

» Track Scan, Repeat, Random Play, Pause, Next/Previous,

» Detachable Faceplate

» Beat EQ preset: Flat, Classic, Pop M, Rock and DSP off

» S-Bass Sound Shaper Contour w/ Indicator

Tuner Features:
» 18FM/6AM Presets 

» Seek, Scan, Station Name Memory, FM Noise Blanker

» Multi-Path Rejection

» Aux Input for SDVD10

» Control Display: Backlighting- Swiss COOL BLUE illumination

» LCD Display:  Negative Image 12 Digit Swiss COOL BLUE 

» Mounting Capability ISO/DIN Chassis

» Elect: Volume, Treble/Bass, Balance, Fader

» 4 Channel Pre-Amp outputs (Front/Rear)
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Class D Amplifiers
All the SDX Series Amplifiers feature a remote subwoofer gain control and variable bass boost. The durability of 
these amps includes double-sided glass epoxy FR-4 circuit boards in addition to high-speed DC-to-DC switching 
power supplies.

SDX

SDX 1000C 1 X 1000 WATTS 
Class D Mono Block
» Proprietary “Swissink” chassis design

» 250 Watts X 1 @ 4 Ohms

» 500 Watts X 1 @ 2 Ohms

» 1000 Watts X 1 @ 1 Ohms

» Fan Cooled

» Full Variable HP/LP X-Over

» Variable Subsonic Filter

» 18db per octave slopes

» Remote Bass Boost Control

» Dimensions: 320 mm (L) x 238 mm (W) x 57mm (H) 

       12.80”(L) x 9.52”(W) x 2.28”(H)

SDX 1500C 1 X 1500 WATTS 
Class D Mono Block
» Proprietary “Swissink” chassis design

» 375 Watts X 1 @ 4 Ohms

» 750 Watts X 1 @ 2 Ohms

» 1500 Watts X 1 @ 1 Ohms

» Fan Cooled

» Full Variable HP/LP X-Over

» Variable Subsonic Filter

» 18db per octave slopes

» Remote Bass Boost Control

» Dimensions: 380 mm (L) x 238 mm (W) x 57mm (H) 

       15.20”(L) x 9.52”(W) x 2.28”(H)

SDX 2000C 1 X 2000 WATTS 
Class D Mono Block
» Proprietary “Swissink” chassis design

» 500 Watts X 1 @ 4 Ohms

» 1000 Watts X 1 @ 2 Ohms

» 2000 Watts X 1 @ 1 Ohms

» Fan Cooled

» Full Variable HP/LP X-Over

» Variable Subsonic Filter

» 18db per octave slopes

» Remote Bass Boost Control

» Dimensions: 450 mm (L) x 238 mm (W) x 57mm (H) 

       18”(L) x 9.52”(W) x 2.28”(H)
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SMA

SDA 6001- 1X600 WATTS 
Class D Mono Block
» Proprietary “Swissink” chassis design

» 300 Watts X1 @ 4 Ohms

» 600 Watts X 1 @ 2 Ohms

» THD: 0.05%

» Fan Cooled

» Full Variable HP/LP X-Over

» Full Variable Subsonic Filter

» 18db per octave slopes

» Remote Bass Boost Control

» Dimensions: 260 mm (L) x 238mm (W) x 57mm (H) 
        10.40”(L) x 9.52”(W) x 2.28”(H)

SMA 2050 -2 X 50 WATTS
Class A/B Full MOSFET 
» Proprietary “Swissink” chassis design

» 50 Watts X 2 @ 4 Ohms

» 75 Watts X 2 @ 2 Ohms

» 150 Watts  X 1 @ 4 Ohms Mono

» THD: 0.05%

» Full Variable HP/LP X-Over

» 18db per octave slopes

» Nickel-plated RCA Jacks 

» Dimensions: 170mm (L) x 238mm (W) x 57mm (H) 

        6.80”(L) x 9.52”(W) x 2.28”(H)

SMA 2125- 2X125 WATTS 
Class A/B Full MOSFET
» Proprietary “Swissink” chassis design

» 125 Watts X 2 @ 4 Ohms

» 220 Watts X 2 @ 2 Ohms

» 350 Watts  X 1 @ 4 Ohms 

» THD: 0.05%

» Full Variable HP/LP X-Over

» 18db per octave slopes

» Nickel-plated RCA Jacks 

» Dimensions: 200mm (L) x 238mm (W) x 57mm (H)

        8”(L) x 9.52”(W) x 2.28”(H)

SMA 4075- 4X725 WATTS 
Class A/B Full MOSFET
» Proprietary “Swissink” chassis design

» 75 Watts X 4 @ 4 Ohms

» 120 Watts X 4 @ 2 Ohms

» 220 Watts  X 2 @ 4 Ohms 

» THD: 0.05%

» Full Variable HP/LP X-Over

» 18db per octave slopes

» Nickel-plated RCA Jacks 

» Dimensions: 250 mm (L) x 238mm (W) x 57mm (H) 

       10”(L) x 9.52”(W) x 2.28”(H)
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Class D Amplifiers 
The Swiss Audio SMX SERIES of amplifiers feature a proprietary chipset for complete full range digital processing 
across the complete spectrum of the sound frequency range. With these results, our amplifiers have added capabili-
ties for high-speed signal processing at extremely low heat dispersion. Eliminating the need for large heat sinks or 
circuit boards. The power-to-size ratio of SMX SERIES Amplifiers sets the standard for mobile audio.

SMX

SMX1000C - 1x1000 Watt Class D Mono Block
» 250watts x 2 @ 4 Ohms 
» 500 watts x 2 @ 2 Ohms 
» 1000 watts x 1 @ 1 Ohms 
» Full Variable HP/LP X-over (50Hz- 250Hz)
» Variable Subsonic Filter  (15Hz – 60Hz)
» Out/In Phase Switching
» Master/Slave on Board Bridging Module
» Bass Boost Control Module 
» Buffered Line Outputs
» THD: 0.04%
» S/N Ratio: >100dB (+/-3dB)
» Frequency Response: 1 watt @ 4 Ohm: 10Hz – 30 KHz
» Dimensions: 290mm (L) x 165mm (W) x 50mm (H)
       11.60” (L) x 6.60” (W) x 2” (H)
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SMX2600C - 2 X 600 WATTS
» 300watts x 2 @ 4 Ohms stereo
» 400 watts x 2 @ 2 Ohms mono
» 600 watts x 1 @ 4 Ohms mono
» Full Variable HP/LP X-over (50Hz- 250Hz)
» Bass Boost Control  
» Buffered Line Outputs
» THD: 0.04%
» S/N Ratio: >100dB (+/-3dB)
» Frequency Response: 1 watt @ 4 Ohm: 10Hz – 30 KHz
» Dimensions: 290mm (L) x 165mm (W) x 50mm (H)
       11.60” (L) x 6.60” (W) x 2” (H)

SMX2400C - 2 X 400 WATTS
» 200 watts x 2 @ 4 Ohms stereo
» 320 watts x 2 @ 2 Ohms mono
» 500 watts x 1 @ 4 Ohms mono
» Full Variable HP/LP X-over (50Hz- 250Hz)
» Bass Boost Control 
» Buffered Line Outputs
» THD: 0.04%
» S/N Ratio: >100dB (+/-3dB)
» Frequency Response: 1 watt @ 4 Ohm: 10Hz - 30 KHz
» Dimensions: 240 mm (L) x 165 mm (W) x 50mm (H)
       9.60” (L) x 6.60” (W) x2” (H)

SMX4600C - 4 X 600 WATTS
» 300 watts x 4 @ 4 Ohms stereo
» 400 watts x 4 @ 2 Ohms mono
» 600 watts x 2 @ 4 Ohms stereo (Bridged)
» Full Variable HP/LP X-over (50Hz- 250Hz)
» Bass Boost Control  
» Buffered Line Outputs
» THD: 0.04%
» S/N Ratio: >100dB (+/-3dB)
» Frequency Response: 1 watt @ 4 Ohm: 10Hz – 30 KHz
» Dimensions: 320mm (L) x 165mm (W) x 50mm (H)
        12.80” (L) x 6.60” (W) x 2” (H)

SMX4400C - 4 X 400 WATTS
» 200 watts x 4 @ 4 Ohms stereo
» 280 watts x 4 @ 2 Ohms stereo
» 400 watts x 2 @ 4 Ohms stereo (Bridged)
» THD: 0.04%
» Full Variable HP/LP X-over (50Hz- 250Hz)
» Bass Boost Control  
» Buffered Line Outputs
» S/N Ratio: >100dB (+/-3dB)
» Frequency Response: 1 watt @ 4 Ohm: 10Hz - 250Hz
» Dimensions: 280mm (L) x 165mm (W) x 50mm (H)
       11.20” (L) x 6.60” (W) x 2” (H)

SMX
 Full Range Hybrid Digital
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SSD5100 Surround Sound Decoder
The SSD5100 DTS™ Surround Sound Decoder when connected to your vehicle’s system offers true 5.1 surround 
processing, with center channel, subwoofer, and front / rear left and right channels.  The SSD5100 includes both 
analog and fiber optic inputs and can decode 5.1 surround sound while offering nine different possible EQ effects 
to the audio signal.  The unit decodes Dolby™ Pro Logic™ and can also create simulated surround sound from any 
stereo signal. 

» DSP Processing: Stream - PCM Dolby™ Digital (AC-3), DTS™ 3D Sound
   - Dolby™ Pro Logic II™, Pro Logic™, Movie, Music

» DSP Surround Presets:  Theater, Hall, Church, Stadium, Live, Jazz, Disco,    
   Pro Logic II™, Pass-through

» Center Delay: 0 – 5m sec (1m sec increments)

» Surround Delay:  0 – 15m sec (1m sec increments)

» Surround Sound Test:  Left, Center, Right, Left Surround, Right Surround

» “ICED SILVER” Brushed Aluminum Front Panel, RED Illumination display

» Separate Outputs for Front, Rear, Center and Subwoofer Channels

» Inputs:  RCA’S / Fiber Optic Cable

» Outputs:  Sub / Front Left / Front Right / Center / Rear Left / Rear Right

» Audio Input:  Digital 24-bit, Analog 48kHz sample rate

» Video Input:  2 Composite 2.2V p-p

» Video Output: 1 Composite 2.2V p-p

» Dimensions:  178mm (W) x 25mm (H) x 175mm (L)
         7”(W) X 1” (H) X 6 15/16 (L)

Processors

SLD10
SBD11

The Swiss Audio line of Signal Processors and Line Drivers are individually crafted to match the amplifiers and over-
all product design criteria that goes into each Swiss Audio product. These products do more than just enhance your 
installation with a refined look and feel. They incorporate the same high-quality performance and specifications of 
Swiss Audio head units, amplifiers and other superior electronics.

SEQ16 - 16-BAND EQUALIZER WITH LINE DRIVER
» “ICED SILVER” Precision-Machined Finish
» Flush or Surface Mount Options
» 16-Band Equalizer
» PWM Switching Power Supply
» Frequency Boost: +/-12dB
» Variable Level Control
» Dual Dynamic VU Meters
» Front and Rear RCA Inputs / Outputs
» S/N Ratio: 90dB
» THD: 0.05%
» Dimensions: 282mm (W) x 206mm (H) x 35mm (L)
          8.11” (W) x 11.1” (H) x 1.38” (L)
 

SBD11 - HIGH PERFORMANCE BASS DRIVER
» “ICED SILVER” Machined-Aluminum Finish
» Flush or Surface Mount Options
» Variable Boost Frequency: 40Hz – 400Hz
» Maximum Output: 7 Volts
» Phase Selector: 0°/180°
» Mode Selector: Stereo/Mono
» Variable Level Control
» Dual Dynamic VU Meters
» PWM Power Supply
» Remote Q, Frequency  and Output Control Module
» Frequency Response: 20Hz to 400Hz
» S/N: >100dB
» THD: 0.07%
» Variable Q Control: 2 – 20
» Dimensions: 152mm (W) x 206mm (H) x 35mm (L)
               8.11” (W) x 5.98” (H) x 1.38” (L)

SLD10 - HIGH PERFORMANCE LINEDRIVER
» “ICED SILVER” Machined Aluminum Finish
» Flush or Surface Mount Options
» Maximum Output: 7 Volts
» PWM Power Supply
» Speaker Level Inputs
» Low-Level Inputs
» Low-Level Outputs
» Variable Adjustments
» Dual Dynamic VU Meters
» Frequency Response: 20Hz to 30 kHz
» S/N: >100dB
» THD: 0.05%
» Dimensions:  152mm (W) x 206mm (H) x 35mm (L)
           8.11” (W) x 5.98” (H) x 1.38” (L)

STX3 - 3-WAY ELECTRONIC CROSSOVER
» “ICED SILVER” Machined Aluminum Finish
» Flush or Surface Mount Options
» Variable Q (2 – 20) 
» Subwoofer Boost @ 45Hz
» Remote Q And Output Control Module
» PWM Power Supply
» Stereo/Mono Subwoofer Switch
» 0/180° Subwoofer Phase Switch
» Band Pass/High Pass Midrange Switch
» Front/Front & Rear Input Switch
» 18dB per Octave Crossover Slopes
» Variable Low Pass Crossover: 40Hz - 400Hz
» Variable Band Pass Crossover: High 40Hz - 800Hz & Low 2 kHz - 7 kHz
» Variable High Pass Crossover: 40Hz - 8 kHz
» 1/10x Crossover Multiplier (High Pass Only)
» Front and Rear RCA Inputs
» Dual Dynamic VU Meters
» Low, Band Pass / Mid, High RCA Outputs
» Variable Input Level Controls
» Variable Output Level Controls
» Dimensions: 242(W) x 206mm (H) x 35mm (L)
         8.11”(W) x 9.53”(H) x 1.38”(L)

SEQ16 STX3
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Swiss Audio introduces the high-capacity PULSE BANK Series of ultra high-speed capacitors designed for audio-
philes with a keen ear and competitors who demand the most superior sonic quality. The series features three mod-
els catering to the demands of high-power and multi-amped systems.

Pulse Bank

SBANK52 - 52 FARAD ULTRA HIGH STORAGE,
HI-SPEED CAPACITOR BANK
» “ICED SILVER” and Brushed Aluminum Rack Mount Housing
» 3-Color Active Status Display
» Maxi LCD Readout of Charge Status
» 14-Volt Continuous Rating – 20 Volt Surge Rating
» Dimensions: 206mm(W) x 120mm(H) x 180mm(L)
           8.11”(W) X 4.72”(H) x 7.09”(L)

SBANK13 - 15 FARAD HI-SPEED
CAPACITOR BANK
» “ICED SILVER” and Brushed Aluminum Rack Mount Housing
» 3-Color LED Active Status Display
» 14 Volt Continuous Rating – 20 Volt Surge Rating
» Dimensions: 206mm(W) x 40mm(H) x 150mm(L)
             8.11”(W) X 1.57”(H) x 5.9”(L)

SBANK1042 - 10 FARAD, 42 VOLT DC ULTRA
HI-SPEED CAPACITOR BANK
» “ICED SILVER” and Brushed Aluminum Rack Mount Housing
» 3-Color Active Status Display
» Maxi LCD Readout of Charge Status
» Dimensions: 206mm(W) x 120mm(H) x 180mm(L)
                        8.11”(W) x 4.72”(H) x 5.9”(L)

SBANK1042

SBANK13

SBANK52

9



Ultra Excursion Subwoofers
The Eagle has landed!  Our competition woofers are now available to the general public.  That’s right!   The new SPL 
series has been used in major European competitions setting records in almost every category and now they are 
available in the US.  

The SPL series is also well balanced, while it will produce outrageous SPL number’s, it’s also a very natural and 
smooth sounding woofer giving bass response a whole new meaning.  From sound quality to SPL, this series will 
knock the competition dead.

SPL

SPL1091
10” ULTRA EXCURSION SUBWOOFERS
» Proprietary Euro Cast Basket
» 10” Ultra Excursion Woofer
» Power Handling: 600 watts RMS
» FATT 50mm / 1.97” Foam Surround
» 110oz Double Stack Strontium Magnets
» Frequency Response: 24Hz-500Hz
» Efficiency: 92dB
» Voice Coil: 75mm / 2.95” 4-layer ASV
» Dual 4 Ohm Coil: 2 Ohm or 8 Ohm operation
» Hole Diameter - 225mm / 2.95”
» Depth - 151mm / 5.94”

SPL1291
10” ULTRA EXCURSION SUB WOOFERS
» Proprietary Euro Cast Basket
» 12” Ultra Excursion Woofer
» Power Handling: 700 watts RMS
» FATT 50mm / 1.97” Foam Surround
» 110oz Double Stack Strontium Magnets
» Frequency Response: 22Hz - 500Hz
» Efficiency: 93dB
» Voice Coil: 75mm / 2.95” 4-layer ASV
» Dual 4 Ohm Coil: 2 Ohm or 8 Ohm operation
» Hole Diameter - 275mm / 10.83”
» Depth - 169mm / 6.65”
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SWL
Extended Excursion Subwoofers

While the SWL series has great excursion and capabilities of achieving huge SPL numbers, this series is designed 
more towards the sound quality listener who likes some volume.  This SWL series has all of the features of its big 
brother the SPL series with a slightly smaller motor structure.  The efficiency is greatly increased and you won’t need 
a power plant to make it loud.

SWL1081
10” EXTENDED EXCURSION WOOFER
» Power Handling: 400 watts RMS
» FATT 50mm / 1.97” Foam Surround
» 70oz Double Stack Strontium Magnets
» Frequency Response: 22Hz - 500Hz
» Efficiency: 91dB
» Voice Coil: 50mm / 1.97” 4-layer ASV
» Dual 4 Ohm Coil: 2 Ohm or 8 Ohm operation
» Mounting Dimensions:
» Hole Diameter - 225mm / 8.86”
» Depth - 137mm / 5.39”

SWL1281
12” EXTENDED EXCURSION WOOFER
Power Handling: 500 watts RMS
FATT 50mm / 1.97” Foam Surround
70oz Double Stack Strontium Magnets
Frequency Response: 20Hz - 500Hz
Efficiency: 92dB
Voice Coil: 50mm / 1.97” 4-layer ASV
Dual 4 Ohm Coil: 2 Ohm or 8 Ohm operation
Hole Diameter - 275mm / 10.83”

Depth - 151mm / 5.94”
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Performance Bass Subwoofers
All SWP Series Woofers feature precision-formed “ICED SILVER” baskets with unique scalloped airflow cutouts,  
non-pressed paper cones (for distortion free reproduction), “ICED SILVER” epoxy-coated cone surfaces, precision-
formed center dust caps, molded-rubber magnet surrounds and protective, oversized chromed T-Yoke and back-
plate structures.

SWP155
15” PERFORMANCE BASS WOOFER
» Power Handling: 600 Watts RMS
» 35mm / 1.38” Foam Surround
» 60 oz Strontium Magnet
» Frequency Response: 21Hz – 1kHz
» Efficiency: 96dB
» Voice Coil: 50mm / 2” 2-Layer ASV
» Dual 4 Ohm Coil: 2 Ohm or 8 Ohm operation
» Hole Diameter: 353mm / 13.9”
» Depth: 163mm / 6.42”
» Single Voice Coil: 50mm / 2” 2-Layer ASV - SWP1551

SWP

SWP125
12” PERFORMANCE BASS WOOFER
» Power Handling: 500 Watts RMS
» 35mm / 1.38” Foam Surround
» 45 oz Strontium Magnet
» Frequency Response: 23Hz – 1kHz
» Efficiency: 94dB
» Voice Coil: 50mm / 2” 4-Layer ASV
» Dual 4 Ohm Coil: 2 Ohm or 8 Ohm operation
» Hole Diameter: 280mm / 11.02”
» Depth: 140mm / 5.51”
» Single Voice Coil: 50mm / 2” 2-Layer ASV - SWP1251

SWP105
10” PERFORMANCE BASS WOOFER
» Power Handling: 400 Watts RMS
» 35mm / 1.38” MID Foam Surround
» 45 oz Strontium Magnet
» Frequency Response: 26Hz – 1kHz
» Efficiency: 93dB
» Voice Coil: 50mm / 2” 4-Layer ASV
» Dual 4 Ohm Coil: 2 Ohm or 8 Ohm operation
» Hole Diameter: 235mm / 9.25”
» Depth: 123mm / 4.84”
» Single Voice Coil: 50mm / 2” 2-Layer ASV - SWP1052

SWP85     
8” PERFORMANCE BASS WOOFER
» Power Handling: 300 Watts RMS
» 35mm / 1.38” MID Foam Surround
» 40 oz Strontium Magnet
» Frequency Response: 28Hz – 1kHz
» Efficiency: 91dB
» Voice Coil: 38mm / 1.5” 4-Layer ASV
» Dual 4 Ohm Coil: 2 Ohm or 8 Ohm operation
» Hole Diameter: 185mm / 7.28”
» Depth: 97mm / 3.82
» Single Voice Coil: 50mm / 2” 2-Layer ASV - SWP85
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SW
Bass Drive Subwoofers

SW Woofer’s feature precision-formed “ICED SILVER” baskets with unique scalloped airflow cutouts, non-pressed 
paper cones (for distortion free reproduction), “ICED SILVER” epoxy-coated cone surfaces, precision-formed center 
dustcaps, molded-rubber magnet surrounds and protective oversized, chromed T-Yokes and back-plate structures.

SW12
12” BASS DRIVE WOOFER
» Power Handling: 400 Watts RMS
» 25mm / .98” Foam Surround
» 40 oz. Strontium Magnet
» Frequency Response: 25Hz – 1kHz
» Efficiency: 92dB
» Voice Coil: Single 4-Ohm, 38mm 2-Layer ASV 
» Hole Diameter: 280mm / 11.02”
» Depth: 131mm / 5.16”
» Dual Voice Coil: 4-Ohm, 38mm 2-Layer ASV - SW121

SW10
10” BASS DRIVE WOOFER
» Power Handling: 300 Watts RMS
» 25mm / .98” Foam Surround
» 40 oz. Strontium Magnet
» Frequency Response: 28Hz – 1kHz
» Efficiency: 91dB
» Voice Coil: Single 4-Ohm 38mm 2-Layer ASV
» Hole Diameter: 235mm / 9.25”
» Depth: 114mm / 4.49”
» Dual Voice Coil 4-Ohm 38mm 2-Layer - SW101
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SAK400 - 4” KEVLAR MATCHED
2-WAY COMPONENT
SPEAKER SYSTEM
» Power Handling: 200 Watts RMS
» Frequency Response: 35Hz to 25kHz
» 4” Mid-Bass w/18 oz. Strontium Magnet
» Woven Matte Black Kevlar 1-Piece Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 28mm Soft Silk Dome Tweeter with
   Neodymium Magnet
» Surface or Flush Mount Options
» Matched Components w/12dB Per Octave  
   Crossover Network Included
» 4-Ohm Impedance
» Sensitivity: 90dB
» Complete Mounting Hardware
» Hole Diameter: 102mm / 4”
» Depth: 55mm / 2.25”

SAK

Tweeters

SAK Kevlar/DIECAST Component Systems
With its unique DIECAST Multi-Fit™ baskets and exquisite attention to detail, this high-power component speaker 
system is the perfect match for any audio installation where perfect “MIRROR” imaging and mid to high frequencies 
are to be showcased.

SAK525 - 5.25” MATCHED
2-WAY COMPONENT
SPEAKER SYSTEM
» Power Handling: 220 Watts RMS
» Frequency Response: 35Hz to 25kHz
» 5.25” Mid-Bass w/20 oz. Strontium Magnet
» Woven Matte Black Kevlar 1-Piece Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 28mm Soft Silk Dome Tweeter with 
   Neodymium Magnet
» Surface or Flush Mount Options
» Matched Components w/12dB Per Octave 
   Crossover Network Included
» 4-Ohm Impedance
» Sensitivity: 90dB
» Complete Mounting Hardware
» Hole Diameter: 1.22mm / 4.8”
» Depth:57mm / 2.28”

SAK650 - 6.5” MATCHED
2-WAY COMPONENT
SPEAKER SYSTEM
» Power Handling: 250 Watts RMS
» Frequency Response: 35Hz to 25kHz
» 6.5” Mid-Bass w/20 oz. Strontium Magnet
» Woven Matte Black Kevlar 1-Piece Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 28mm Soft Silk Dome Tweeter with 
   Neodymium Magnet
» Surface or Flush Mount Options
» Matched Components w/12dB Per Octave
   Crossover Network Included
» 4-Ohm Impedance
» Sensitivity: 90dB
» Complete Mounting Hardware
» Hole Diameter: 130mm / 5.75”
» Depth: 76mm / 3”

STN25 -
25mm Silk Soft Dome
Neodymium Magnet
Tweeters
» CPF™ Contoured Precision-Formed
   Dome for Superior Dispersion
» Power Handling: 100 Watts RMS
» Surface and Flush Mount Options
» Frequency Response: 3kHz to 20kHz
» High-Temp Ferro-Fluid Cooled
» Voice Coil
» Neodymium Magnet
» 4-Ohm Impedance
» Sensitivity: 91dB

STP27 -
13mm PEI Dome
Neodymium Magnet
Tweeters
» SPF™ Spherical Precision-Formed
   Dome for Superior Dispersion
» Power Handling: 120 Watts RMS
» Tilt/Swivel - Surface or Flush 
   Mount Options
» Frequency Response: 1.8kHz to 21kHz
» High-Temp Ferro-Fluid Cooled
» Voice Coil
» Neodymium Magnet
» 4-Ohm Impedance 
» Sensitivity: 94dB

STC20 -
20mm Ceramic Dome
Tweeters
» SPF™ Spherical Precision-Formed
   Dome for Superior Dispersion
» Power Handling: 100 Watts RMS
» Supplied with Surface and Flush
   Mount Options
» Frequency Response: 3kHz to 22kHz
» High-Temp Ferro-Fluid Cooled
» Voice Coil
» Neodymium Magnet
» 4-Ohm Impedance
» Sensitivity: 88dB

STB19 -
20mm Titanium Dome
Tweeters
» SPF™ Spherical Precision-Formed
   Dome for Superior Dispersion
» Power Handling: 80 Watts RMS
» Tilt/Swivel - Surface or Flush
   Mount Options
» Frequency Response: 3kHz to 20kHz
» High-Temp Ferro-Fluid Cooled
» Voice Coil
» Neodymium Magnet
» 4-Ohm Impedance
» Sensitivity: 91dB
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SAC
SAC525 - 5.25” MATCHED 3-WAY
COMPONENT SYSTEM
» Power  Handling: 120 Watts RMS
» Frequency Response: 35Hz to 25kHz
» 5.25” Mid-Bass w/15 oz. Strontium Magnet
» Hole Diameter: 112mm / 4.4”Depth: 51mm / 2”
» 4” Mid Range w/8oz Strontium Magnet
» Hole Diameter: 102mm / 4” Depth: 51mm / 2”
» Woven “ICED SILVER” 1-Piece Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Ultra Compact Neodymium Titanium Tweeter
» Surface or Flush Mount Options
» Matched Component 12dB Per Octave Crossover 
   Network
» 4-Ohm Impedance
» Sensitivity: 90dB
» Complete Mounting Hardware

SAC650 - 6.5” MATCHED 3-WAY
COMPONENT SYSTEM
» Power Handling: 120 Watts RMS
» Frequency Response: 30Hz - 25kHz
» 6.5” Mid-Bass w/ 20 oz. Strontium Magnet
» Hole Diameter: 130mm / 5.63” Depth: 71mm / 2.8”
» 4” Mid Range w/ 8oz Strontium Magnet
» Hole Diameter: 102mm / 4”Depth: 51mm / 2”
» Woven “ICED SILVER” 1-Piece Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Ultra Compact Neodymium Titanium Tweeter
» Surface or Flush Mount Options
» Matched Component 12dB Per Octave Crossover Network
» 4-Ohm Impedance
» Sensitivity: 91dB
» Complete Mounting Hardware

SAC5252 - 5.25” MATCHED 2-WAY
COMPONENT SYSTEM
» Power Handling: 100 Watts RMS
» Frequency Response: 35Hz to 25kHz
» 5.25” Mid-Bass w/15 oz. Strontium Magnet
» Woven “ICED SILVER” 1-Piece Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Ultra Compact Neodymium Titanium Tweeter
» Surface or Flush Mount Options
» Matched Component 12dB Per Octave Crossover Network
» 4-Ohm Impedance
» Sensitivity: 90dB
» Hole Diameter: 112mm / 4.4”Depth: 51mm / 2”
» Complete Mounting Hardware

SAC6502 - 6.5” MATCHED 2-WAY
COMPONENT SYSTEM
» Power Handling: 100 Watts RMS
» Frequency Response: 35Hz to 25kHz
» 6.5” Mid-Bass w/15 oz. Strontium Magnet
» Woven “ICED SILVER” 1-Piece Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Ultra Compact Neodymium Titanium Tweeter
» Surface or Flush Mount Options
» Matched Component 12dB Per Octave Crossover Network
» 4-Ohm Impedance
» Sensitivity: 90dB
» Hole Diameter: 140mm / 5.63”Depth: 61mm / 2.4”
» Complete Mounting Hardware

SAC700 - 6.5” MATCHED 2-WAY DIECAST
MULTI-FIT™ COMPONENT SYSTEM
» Power Handling: 150 Watts RMS
» Frequency Response: 30Hz to 25kHz
» 15 oz. Strontium Magnet
» Silver Electro-Plated Glass Fiber Woven Cone
» “ICED SILVER” DIECAST Multi-Fit™ Basket
» Butyl Rubber Surround
» 30mm - 2-Layer Voice Coil
» 1” Titanium Dome Tweeter
» Surface or Flush Mount
» Matched Component 12dB Per Octave Crossover Network
» 4-Ohm Impedance
» Sensitivity: 91dB
» Hole Diameter: 147mm / 5.8”Depth: 61mm / 2.4”
» Complete Mounting Hardware
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Full Range Speaker Systems
The SAX SERIES of Full Range Speakers are designed to replace original equipment speakers in vehicles where 
component speaker systems are not practical or desirable. These speakers deliver the same performance as our 
high quality component speakers in more common configurations that are easily installed in most of today’s popular 
vehicles. The SAX SERIES consists of 7 models from 3.5” to 6 x 9” covering a wide range of installation needs.

SAX

SAX692
6 X 9” COAXIAL SPEAKER SYSTEM
» Power Handling: 200 Watts RMS
» Frequency Response: 150Hz to 20kHz
» 25 oz. Magnet
» Gun Metal Plated Basket
» Milled PPI Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Titanium Dome Tweeter
» 4-Ohm Impedance
» Sensitivity: 91dB
» Hole Diameter: 221mm / 5.8”
» Depth: 78mm / 3.25”
» Complete Mounting Hardware and Grilles

SAX682
6 X 8” COAXIAL SPEAKER SYSTEM
» Power Handling: 100 Watts RMS
» Frequency Response: 150Hz to 20kHz
» 10 oz. Magnet
» Gun Metal Plated Basket
» Milled PPI Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Silk Tweeter
» 4-Ohm Impedance
» Sensitivity: 91dB
» Hole Diameter: 183 x 129mm / 7.2” x 5.1”
» Depth: 63mm / 2.5”
» Complete Mounting Hardware and Grilles

SAX652
6.5” COAXIAL SPEAKER SYSTEM
» Power Handling: 120 Watts RMS
» Frequency Response: 150Hz to 20kHz
» 15 oz. Magnet
» Gun Metal Plated Basket
» Milled PPI Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Silk Tweeter
» 4-Ohm Impedance
» Sensitivity: 91dB
» Hole Diameter: 152mm / 5.8”
» Depth: 53mm / 2.1”
» Complete Mounting Hardware and Grilles
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SAX

SAX522
5.25” COAXIAL SPEAKER SYSTEM
» Power Handling: 100 Watts RMS
» Frequency Response: 150Hz to 20kHz
» 10 oz. Magnet
» Gun Metal Plated Basket
» Milled PPI Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Silk Tweeter
» 4-Ohm Impedance
» Sensitivity: 91dB
» Hole Diameter: 122mm / 4.8”
» Depth: 58mm / 2.3”
» Complete Mounting Hardware and Grilles

SAX462
4 X 6” COAXIAL SPEAKER SYSTEM
» Power Handling: 100 Watts RMS
» Frequency Response: 150Hz to 20kHz
» 10 oz. Magnet
» Gun Metal Plated Basket
» Milled PPI Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Silk Tweeter
» 4-Ohm Impedance
» Sensitivity: 91dB
» Hole Diameter: 129 x 91mm / 5.10” x 3.6”
» Depth: 63mm / 2.5”
» Complete Mounting Hardware and Grilles

SAX422
4” COAXIAL SPEAKER SYSTEM
» Power Handling: 100 Watts RMS
» Frequency Response: 150Hz to 20kHz
» 10 oz. Magnet
» Gun Metal Plated Basket
» Milled PPI Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Silk Tweeter
» 4-Ohm Impedance
» Sensitivity: 91dB
» Hole Diameter: 79mm / 3.12”
» Depth: 58mm / 2.3”
» Complete Mounting Hardware and Grilles

SAX322
3.5” COAXIAL SPEAKER SYSTEM
» Power Handling: 80 watts RMS
» Frequency Response: 150Hz to 20kHz
» 8 oz. Magnet
» Gun Metal Plated Basket
» Milled PPI Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Silk Tweeter
» 4-Ohm Impedance
» Sensitivity: 91dB
» Hole Diameter: 81mm / 3.2”
» Depth: 51mm / 2”
» Complete Mounting Hardware
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Full Range Speaker Systems 
The entire Swiss Audio SAF Series of Full Range Speakers is built to exacting standards with precision-wound voice 
coils, ultra compact tweeters, audibly transparent bridging systems and “warm” sounding, “ICED SILVER” woven 
cones on all drivers, in the Series.

SAF693 - 6 X 9” TRI-AXIAL SPEAKER SYSTEM
» Power Handling: 180 Watts
» Frequency Response: 25Hz to 20kHz
» “ICED SILVER” Basket
» Silver Woven Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 3” PEI Midrange
» 1” Neodymium Aluminum Coated Poly Mid Tweeter
» 4-Ohm Impedance
» Sensitivity: 95dB
» Hole Diameter: 152mm x 229mm / 6” x 9”
» Depth: 91mm / 3.6”
» Complete Mounting Hardware and Grilles

SAF

SAF692 - 6 X 9”COAXIAL SPEAKER SYSTEM
» Power Handling: 140 Watts
» Frequency Response: 28Hz to 20kHz
» “ICED SILVER” Basket
» Silver Woven Fiber Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Aluminum Coated Poly Mid Tweeter
» 4-Ohm Impedance
» Sensitivity: 93dB
» Hole Diameter: 152mm x 229mm / 6” x 9”
» Depth: 91mm / 3.6”

» Complete Mounting Hardware and Grilles

SAF680 - 6 X 8” CO-AXIAL SPEAKER SYSTEM
» Power Handling: 100 Watts
» Frequency Response: 60Hz to 20kHz
» “ICED SILVER” Basket
» Silver Woven Fiber Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Aluminum Coated Poly Mid Tweeter
» 4-Ohm Impedance
» Sensitivity: 93dB
» Hole Diameter: 188mm x 129mm / 7.4” x 5.1”
» Depth: 66mm / 2.6”
» Complete Mounting Hardware and Grilles

SAF630 - 6.5” TRI-AXIAL SPEAKER SYSTEM
» Power Handling: 120 Watts
» Frequency Response: 50Hz to 20kHz
» “ICED SILVER” Basket
» Silver Woven Fiber Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1 3/4” PEI Midrange
» 1”Neodymium Aluminum Coated Poly Mid Tweeter
» 4-Ohm Impedance
» Sensitivity: 94dB
» Hole Diameter: 150mm / 5.9”
» Depth:  66mm / 2.6”
» Complete Mounting Hardware and Grilles

SAF410 - 4 X 10” COAXIAL SPEAKER SYSTEM
» Power Handling: 100 Watts
» Frequency Response: 50Hz to 20kH
» “ICED SILVER” Basket
» Silver Woven Fiber Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Aluminum Coated Poly Mid Tweeter
» 4-Ohm Impedance
» Sensitivity: 93dB
» Hole Diameter: 188mm x 129mm / 9.6” x 4”
» Depth:  66mm / 2.6”
» Complete Mounting Hardware and Grilles
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SAF
SAF620 - 6.5” CO-AXIAL SPEAKER SYSTEM
» Power Handling: 100 Watts
» Frequency Response: 50Hz to 20kHz
» “ICED SILVER” Basket
» Silver Woven Fiber Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Aluminum Coated Poly Mid Tweeter
» 4-Ohm Impedance
» Sensitivity: 94dB
» Hole Diameter: 150mm / 5.9”
» Depth: 66mm / 2.6”
» Complete Mounting Hardware and Grilles

SAF530 - 5.25” TRI-AXIAL SPEAKER SYSTEM
» Power Handling: 80 Watts
» Frequency Response: 60Hz to 20kHz
» “ICED SILVER” Basket
» Silver Woven Fiber Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1 1/4” PEI Midrange
» 1” Neodymium Aluminum Coated Poly Mid Tweeter
» 4-Ohm Impedance
» Sensitivity: 93dB
» Hole Diameter: 104mm / 4.11” 
» Depth: 51mm / 2”
» Complete Mounting Hardware and Grilles

SAF520 - 5.25” COAXIAL SPEAKER SYSTEM
» Power Handling: 60 Watts
» Frequency Response: 60Hz to 20kHz
» “ICED SILVER” Basket
» Silver Woven Fiber Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Aluminum Coated Poly Mid Tweeter
» 4-Ohm Impedance
» Sensitivity: 93dB
» Hole Diameter: 104mm / 4.11”
» Depth: 51mm / 2”
» Complete Mounting Hardware and Grilles

SAF460 - 4 X 6” COAXIAL SPEAKER SYSTEM
» Power Handling: 60 Watts
» Frequency Response: 60Hz to 20kHz
» “ICED SILVER” Basket
» Silver Woven Fiber Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Aluminum Coated Poly Mid Tweeter
» 4-Ohm Impedance
» Sensitivity: 93dB
» Hole Diameter: 99mm x 147mm / 3.9” x 5.8”
» Depth: 56mm / 2.2”
» Complete Mounting Hardware and Grilles

SAF420 - 4” COAXIAL SPEAKER SYSTEM
» Power Handling: 50 Watts
» Frequency Response: 90Hz to 20kHz
» “ICED SILVER” Basket
» Silver Woven Fiber Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 1” Neodymium Aluminum Coated Poly Mid Tweeter 
» 4-Ohm Impedance
» Sensitivity: 93dB
» Hole Diameter: 101mm / 4”
» Depth: 51mm / 2”
» Complete Mounting Hardware and Grilles

SAF320 - 3.5” COAXIAL SPEAKER SYSTEM
» Power Handling: 40 Watts
» Frequency Response: 150Hz to 20kHz
» “ICED SILVER” Basket
» Silver Woven Fiber Cone
» Butyl Rubber Surround
» 2-Layer High-Temp ASV Voice Coil
» 3/4” Neodymium Aluminum Coated Poly Mid Tweeter
» 4-Ohm Impedance
» Sensitivity: 91dB
» Hole Diameter: 76mm / 3”
» Depth: 28mm / 1.1”
» Complete Mounting Hardware
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Loaded Bandpass Enclosures
Swiss Audio Bandpass Enclosures feature unique angled back panels, with clear viewing windows, red neon lighting, 
and black universal textured urethane finish. The enclosures are specifically designed for maximum bass effect in a 
small enclosure. The tuned VENTURI ports add a substantial level to the efficiency and overall bass performance of 
these enclosures.

SBP

SBP112 - SINGLE 12” LOADED
BANDPASS ENCLOSURE
» Handling Capacity: 400 Watts  
» Sensitivity: 100dB
» Twin Tuned Spun-Aluminium VENTURI Ports
» Black Textured Urethane Finish
» Clear Viewing Window
» Red Interior Neon Lighting
» 12” Non-Pressed Paper Cone Woofer
» 45oz Strontium Magnet,
» 2” Dual VC
» 4-Ohm Impedance 
» Bumped Back-plate
» Extended and Vented Pole Piece
» Recessed Terminal Cup with Chrome-Plated Connectors
» Frequency Response: 30Hz to 150Hz
» Dimensions: 628mm (W) x 433mm (H) x 456mm (D)
        (Bottom) x 295mm (Top) 24.72”
       (W) x 17.05” (H) x 17.95” (D) (Bottom) x 11.61” (Top)

SBP210 - DUAL 10” LOADED
BANDPASS ENCLOSURE
» Handling Capacity: 600 Watts 
» Sensitivity: 101dB
» Quad Tuned Spun-Aluminium VENTURI Ports
» Black Textured Urethane Finish
» Clear Viewing Window
» Red Interior Neon Lighting
» 2 x 10” Non-Pressed Paper Cone Woofers
» 45oz Strontium Magnets
» 2” Dual VC 
» 4-Ohm Impedance
» Bumped Back-plate
» Extended and Vented Pole Pieces
» Recessed Terminal Cup with Chrome-Plated Connectors
» Frequency Response: 30Hz to 150Hz
» Dimensions: 718mm (W) x 485mm (H) x 384mm (D)
       (Bottom) x 280mm (Top) 28.27”
       (W) x 19.09” (H) x 15.12” (D) (Bottom) x 11.02” (Top)

SBP110 - SINGLE 10” LOADED
BANDPASS ENCLOSURE
» Handling Capacity: 300 Watts 
» Sensitivity: 98dB
» Twin Tuned Spun-Aluminium VENTURI Ports
» Black Textured Urethane Finish
» Clear Viewing Window
» Red Interior Neon Lighting
» 10” Non-Pressed Paper Cone Woofer
» 45oz Strontium Magnet,
» 2” Dual VC 
» 4-Ohm Impedance
» Bumped Back-plate
» Extended and Vented Pole Piece
» Recessed Terminal Cup with Chrome-Plated Connectors
» Frequency Response: 32Hz to 150Hz
» Dimensions: 573mm (W) x 433mm (H) x 396mm (D)
        (Bottom) x 280mm (Top) 22.56”
        (W) x 17.05” (H) x 15.59” (D) (Bottom) x 11.02”(Top)

SBP212 - DUAL 12” LOADED
BANDPASS ENCLOSURE
» Handling Capacity: 800 Watts 
» Sensitivity: 103dB
» Quad Tuned Spun-Aluminiumv VENTURI Ports
» Black Textured Urethane Finish
» Clear Viewing Window
» Red Interior Neon Lighting
» 2 x 12” Non-Pressed Paper Cone Woofers
» 45oz Strontium Magnet
» 2” Dual VC 
» 4-Ohm Impedance
» Bumped Back-plate
» Extended and Vented Pole Pieces
» Recessed Terminal Cup with Chrome-plated Connectors
» Frequency Response: 28Hz to 150Hz
» Dimensions: 768mm (W) x 485mm (H) x 456mm (D)
       (Bottom) x 295mm (Top) 11.61”
       (W) x 19.09” (H) x 17.95” (D) (Bottom) 11.61”(Top)
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SPB
Loaded Truck Enclosures

Swiss Audio Ported Truck Enclosures are specially tuned to enhance bass response with a unique baffle approach 
to common bass-reflex technology. Both units feature front-firing woofers with top-loaded tuned ports in polished 
spun-aluminum and black universal textured urethane finish.

SPB10 - 10” SINGLE PORTED SLIM PROFILE
TRUCK ENCLOSURE
» Handling Capacity: 300 Watts
» Sensitivity: 92dB
» Tuned Spun-Aluminium VENTURI Port
» Black Textured Urethane Finish
» 10” Non-Pressed Paper Cone Woofer with Electro-Plated Laminate
» 45oz. Strontium Magnet 
» 2” Dual VC 
» 4-Ohm Impedance
» Bumped Back-plate 
» Extended and Vented Pole Piece
» Recessed Terminal Cup with Chrome-Plated Connectors
» Frequency Response: 28Hz to 120Hz
» Dimensions: 525mm (W) x 370mm (H) x 180mm (D) (Bottom) x 130mm (Top)

        20.67” (W) x 14.57” (H) x 7.09” (D) (Bottom) x 5.12”(Top)

SPB12 - 12” SINGLE PORTED SLIM PROFILE
TRUCK ENCLOSURE
» Handling Capacity: 300 Watts
» Sensitivity: 94dB
» Tuned Spun-Aluminium VENTURI Port
» Black Textured Urethane Finish
» 12” Non-Pressed Paper Cone Woofer with Electro-Plated Laminate
» 45oz. Strontium Magnet
» 2” Dual VC
» 4-Ohm Impedance
» Bumped Back-plate
» Extended and Vented Pole Piece
» Recessed Terminal Cup with Chrome-Plated Connectors
» Frequency Response: 28Hz to 120Hz
» Dimensions: 560mm (W) x 400mm (H) x 210mm (D) (Bottom) x 160mm (Top)
        22.05” (W) x 15.75” (H) x 8.27” (D) (Bottom) x 6.3” (Top)
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SCP1KIT - 1 FARAD CAPACITOR KIT
» 20-Volt continuous / 24 volt-surge
» 4-Digit voltage display
» Auto on/off four-digit display
» 2 red LED indicator lights
» Reverse polarity Warning
» Under/Over voltage warning
» Voltage display calibration
» Clear ABS mounting clamps
» Distribution Block
» 3’ Power Cable W/Terminal
» 3’ Ground Cable w/Terminal
» Mounting hardware

SCP1 - 1 FARAD CAPACITOR
» 20-Volt continuous / 24 volt-surge
» 4-Digit voltage display
» Auto on/off four-digit display
» 2 red LED indicator lights
» Reverse polarity Warning
» Under/Over voltage warning
» Voltage display calibration
» Clear ABS mounting clamps

Accessories
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MODEL # SKIT8, SWISS AUDIO 8 GAUGE AMP KIT
» 20 ft. 8 gauge clear RED braided power cable
» 3 ft. 8 gauge clear SILVER braided ground cable
» 12 ft. 12 gauge clear with one GOLD and one SILVER speaker wire
» 17 ft. twisted RED AND SILVER RCA leads with clear sleeve cover.
» 17 ft. 18 gauge BLUE remote turn on lead
» 6 ft. medium BLACK split loom
» 40 amp AGU fuse w/AGU CHROME fuse holder

MODEL # SKIT4, SWISS AUDIO 4 GAUGE AMP KIT
» 20 ft. 4 gauge clear SILVER braided power cable
» 3 ft. 4 gauge clear BLACK braided ground cable
» 12 ft. 12 gauge clear with one GOLD and one SILVER speaker wire
» 17 ft. twisted ORANGE AND SILVER RCA leads with clear sleeve cover.
» 17 ft. 18 gauge BLUE remote turn on lead
» 6 ft. medium BLACK split loom
» 80 amp AGU fuse w/AGU CHROME fuse holder

Accessories

23



Copyright 2005 Swiss Audio, Inc. All rights reserved.
Any unauthorized reproduction or use of Swiss Audio Inc. logos,

images or design elements is strictly prohibited by law.
Specifications subject to change without notice.

PROUD MEMBER OF

24




